読者です 読者をやめる 読者になる 読者になる

Ubuntu 12.04で最新のGitを使用したい

最新である必要はないだが、gitconfigでincludeディレクティブが使用したい。
includeディレクティブはGit 1.7.10以降で使用できるのだが、
Ubuntu 12.04でのapt-get installでインストールできるパッケージは、
1.7.9.5-1 のようだ。(2013/1/20現在)


ソースコードからコンパイル、インストールするのではなく
パッケージ管理した方がいいんだろうな。
ということで調べたのでメモ。
ppaのリポジトリに追加すればできるらしい。




手順

  • gitはまだインストールしてない状態
$ git --verison
プログラム 'git' はまだインストールされていません。  次のように入力することでインストールできます:
sudo apt-get install git
  • インストール
$sudo apt-add-repository ppa:git-core/ppa
$sudo apt-get update
$sudo sudo apt-get install git-core
  • バージョンの確認
$git --version
git version 1.8.0.3


もっと適切な方法があれば教えて下さい。

広告を非表示にする