読者です 読者をやめる 読者になる 読者になる

Thunderbird 5で互換性がないアドオンを動かす方法

Thunderbird


3.1系からバージョン4はスキップして、5が公開された、今後は、Firefoxと同様に
6週間ごとにバージョンアップするそうだ。
Thunderbirdを使ってるメリットとして、抱負な豊富なアドオンにあると思う。
必要な分だけ自分で足せる点がいい。
(これって基本機能には不満足ってことかな??)


そのThunderbird 5にすると、アドオンが無効になってしまうから
困ったもんだ。


Nightly Tester Tools 3.1.5.1 は入れてあったのだが
いくつかのアドオンが互換性がないとう理由でグレーアウトになってしまった。


慌てて、Nightly Tester Toolsを更新したが、これが最新バージョンのようだ。


3.1.5.1の互換性は、Thunderbird 3.1 - 7.0a1 になってるのだが、なんででしょう?

設定変更前のアドオンの状態



設定変更

ツール > オプション の 詳細タブ で 設定エディタ をクリック

動作保証対象外になります!
プログラムの高度な設定を変更すると、安定性、セキュリティ、パフォーマンスに深刻な
問題を引き起こす恐れがあります。設定変更による影響を完全に理解してる場合に限ってご利用ください。

同意できる方のみ、「最新の注意を払って使用する」 をクリック


適当な項目のところで、右クリック > 新規作成 >真偽値
新しい真偽値の設定名 に 「extensions.checkCompatibility.5.0 」を入れる
値は、「false」を選ぶ



設定変更後

互換性のチェックが無効になって、再起動すれば有効化されるようになる


再起動すると、有効になる



使えるようになったアドオン

  • AddressBookTab 1.4.1
  • Auto Address Cleaner 1.0.3
  • CompactHeader 1.4.0
  • ConfigDate 0.7.4
  • Display Mail User Agent 1.6.6
  • Folder Account 3.1
  • Lightning 1.0b4
  • MoreLayouts 2.1
  • Personas 1.6.2
  • Provider for Google Calendar 0.8
  • qfb-pivot 1.0
  • Remove Duplicate Messages (Alternate) 0.3.7
  • Shockwave Flash 10.0.42.34
  • SmartTemplate 0.6.0
  • ルーラーバー (Ruler Bar) 0.4.2011020301
  • TB Tabloc 0.1.0
  • Nightly Tester Tools 3.1.6 使えるようになったと言えるのだろうか・・・

動作がおかしかったアドオン

  • Timeline 0.3.3 は表示がおかしかったので無効にしている。
広告を非表示にする